Having issues with Google Maps functionality of Ultimate Addons? Most probably, this should be due to Multiple Google Maps APIs loaded on your site.

When do Multiple Google Maps APIs load?

Any plugin that offers Google Maps functionality needs to load the map through APIs. If you have multiple plugins installed on your site that offer Google Maps or if the theme you’re using comes with Google Maps functionality as well, there are chances you might face this issue.

How to confirm whether you have Multiple Google Maps APIs loaded on the site?

If you’re using Chrome, you may open the console and see if you have an error there similar as this –

Screen Shot 2016-05-26 at 11.55.43 AM

(Click to enlarge the image)

What can you do to fix this?

Ideally, any theme or plugin should load Google Maps API only on the pages where you’re using it’s functionality. (In Ultimate Addons, we do load our API on pages where you would use Google Maps functionality of Ultimate Addons) However, many themes & plugins load the API throughout the website, which causes such conflict.

If your theme / plugin is loading Map API the in header, add the following line into your theme’s functions.php file –

define('DISABLE_ULTIMATE_GOOGLE_MAP_API', true);

which will disable the API that loads through Ultimate Addons and will use other API that’s loaded by other plugins / theme and it will most probably fix the issue.

However if the theme / plugin is loading Map API in the footer, you would need to connect with your theme / plugin author and request information on how you can disable their API from certain pages (or better load only on pages where you’re using it).